Sony and Konica Minolta Cameras Forum

Sony Digital Cameras Forum This forum is for discussing Sony digital cameras and the Sony Alpha DSLR and Konica Minolta Maxxum / Dynax SLR systems.
Sony Digital SLR Reviews >>
Sony Above 10-Megapixel Digital Camera Reviews >>
Sony 8 to 10-Megapixel Digital Camera Reviews >>
Sony 6 to 7-Megapixel Digital Camera Reviews >>
All Sony Photography Product Reviews >>
Sony Digital Cameras & History Page >>
Results 1 to 5 of 5
  1. #1
    Member PWhite214's Avatar
    Join Date
    Feb 2009
    Location
    Houston, Texas, USA
    Posts
    482

    My Sigma lenses on the A77

    I only have four Sigma lenses:
    150-500mm HSM ETC. Relatively new
    300mm f4 I don't know how old
    75-200 f2.8 - 3.5 I don't know how old
    400mm f5.6 Really old, light grey


    All work on the A77.

    The 75-200 and 400 are not recognized on the A700.

    Oh, well, weird things with Sigma lenses are common knowledge.

    Phil

  2. #2
    Senior Shooter Greg McCary's Avatar
    Join Date
    Jun 2006
    Location
    Rome Ga.
    Posts
    10,550

    Re: My Sigma lenses on the A77

    That is strange. I had a couple of Sigma lenses in the past but sold them. What I did have were more prone to flare and ghost. Under normal lighting conditions they were fine.
    I am like Barney Fife, I have a gun but Andy makes me keep the bullet in my pocket..

    Sony a99/a7R

  3. #3
    Member PWhite214's Avatar
    Join Date
    Feb 2009
    Location
    Houston, Texas, USA
    Posts
    482

    Re: My Sigma lenses on the A77

    I am not sure what prompted me to try the 400 and 75-200 on the A77. I was surprised to find they worked. I don't think the 400 worked on any thing newer than my Maxxum 7000.

    I tested the 150-500 in the store before purchasing the A77. If it had not worked, I would have checked on the cost of re-chipping. That lens hardly ever stays at home without me.

    Phil

  4. #4
    Junior Member
    Join Date
    Apr 2014
    Posts
    12

    Re: My Sigma lenses on the A77

    sorry just getting my post count up

  5. #5
    Junior Member
    Join Date
    Nov 2014
    Posts
    11

    Re: My Sigma lenses on the A77

    Do you have any image samples?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Latest PhotographyREVIEW Articles



Latest Camera News