Digital SLR Cameras Forum

Digital SLRs Forum Discuss digital SLRs, lenses, RAW conversion, or anything else related to digital SLRs. You may also want to see the Nikon, Canon, and Sony camera forums.
Digital Camera Pro Reviews >>
Read and Write Digital SLR Reviews >>
Digital SLR Buyer's Guide >>
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Feb 2005
    Location
    Secaucus, NJ, USA
    Posts
    2

    Angry Canon 300D (Digital Rebel) Mirror does not move (err 99) after 97 shots

    Got my Drebel only this Tuesday with a Canon 28-135 and a Tokina lens. Everything worked fine until I tried bulb tonight in my house. I started with the smallest aperture (f/22) with the 28-135 lens and held the shutter for several seconds, and got a completely black picture. I stopped up several times and still got black picture, until I got err 99.

    Tried everything I could, and it's always err 99. Somehow I found out that the mirror is dead. Not any mode, any parameter, even Sensor Clean doesn't make it move. I can only flip it up manually.

    And when I tilt the body up for about 60 degrees, or left/right for about 45 degrees, I can hear a slight rattle sound coming from inside the body.

    The only conclusion I can get is that the mirror flipping mechanism is fried. Maybe it's caused by bulb.

    If that's indeed the case, I have to say it is the biggest piece of s*** I've ever bought in my life. My last dc is Canon Pro 90 IS, which I used for 4 years and shot may be more than 10K pictures, never had any problem. I'm so sorry that I fell for the stupid rebate and bought 300D instead of 10D.

    Anybody with similar experiences? Any idea/suggestion would be greatly appreciated!
    Last edited by huazheng; 02-05-2005 at 11:03 PM. Reason: Title not clear

  2. #2
    Ghost
    Join Date
    Dec 2003
    Location
    Crystal Lake, IL
    Posts
    1,029

    Re: Mirror does not move (err 99) after 97 shots

    Well, things break. Call Canon up.

    Regarding the noise you heard, it may have just been the orientation sensor in the camera. It's normal on some camera's to be able to hear it slightly although I've never noticed it myself.

    Error 99 is definetely not good. Often, it can be caused by bad contact between the camera and the lens. Try putting the other lens on it and see what happens.

    I understand your frustration.

  3. #3
    Junior Member
    Join Date
    Feb 2005
    Location
    Secaucus, NJ, USA
    Posts
    2

    Re: Canon 300D (Digital Rebel) Mirror does not move (err 99) after 97 shots

    TKS Trevor for your quick response!

    I tried my only other lens, a Tokina 80-400, same result. No other function, such as AF, AE, image viewing, menu, etc. has any problem, so it really looks like a simple but devastating mirror mechanical problem to me. Will call Canon up.

    You're probably right about the noise. The manual does mention that the orientation sensor makes a noise when the camera orientation changes.

  4. #4
    Nikon Samurai #14 DownByFive's Avatar
    Join Date
    Jan 2005
    Location
    Idaho
    Posts
    341

    Re: Canon 300D (Digital Rebel) Mirror does not move (err 99) after 97 shots

    I've read that removing the battery for a few minutes will take care of this. I think there is also a firmware upgrade to fix it...but I haven't been keeping on Canon tech stuff lately.


    I don't know how to put this, but...I'm kind of a big deal...People know me.

    My Dumb Web Page

  5. #5
    Ghost
    Join Date
    Dec 2003
    Location
    Crystal Lake, IL
    Posts
    1,029

    Re: Canon 300D (Digital Rebel) Mirror does not move (err 99) after 97 shots

    Error 99 is a generic error code. Many things could be wrong and/or fix the problem. Try everything people tell you to try as long as it's not damaging If it comes back, contact Canon or exchange it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Err 99, shutter damage, Help !
    By Peter E in forum Digital SLRs
    Replies: 6
    Last Post: 01-27-2005, 05:37 PM
  2. 10D Err 99 Issue
    By katt in forum Digital Cameras - General
    Replies: 3
    Last Post: 11-07-2004, 02:56 PM
  3. The infamous ERR 99 on the 10D
    By Lionheart in forum Help Files
    Replies: 2
    Last Post: 04-19-2004, 11:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •