Results 1 to 10 of 10
  1. #1
    Active Amateur havana_joe's Avatar
    Join Date
    Dec 2009
    Location
    Mansfield, MA
    Posts
    182

    4 GB Kingston SDHC- E-PL1 issue?

    So, this is a bit odd, anyone have any thoughts?

    I just bought an Olympus E-PL1, and it works great, but it seems to be incompatible with my 4 GB Kingston SDHC card. This card worked fine in my Nikon D40, but when I try to use it in the E-PL1 I get "card error" and "write protect" errors, even with the write protect notch off. I formatted it in camera, and I still get the errors. If I format it in my PC and then put it back in the camera I can take 3-4 pictures before the errors come up again.

    The camera works fine with my 2 GB Sandisk SD card, and I have several, but I really wanted to use the 4 GB card. The card works fine through my PC card reader- I copied and deleted a bunch of files, no problem. Thoughts?
    http://havanajoe08.shutterfly.com/

    Olympus E-PL1

    Feel free to edit my photos!

  2. #2
    Senior Member OldClicker's Avatar
    Join Date
    Aug 2008
    Location
    Mundelein, IL USA
    Posts
    4,075

    Re: 4 GB Kingston SDHC- E-PL1 issue?

    At least half of the card problems I hear about are Kingston. - TF
    -----------------
    I am no better than you. I critique to teach myself to see.
    -----------------
    Feel free to edit my photos or do anything else that will help me learn.
    -----------------
    Sony/Minolta - way more gear than talent.

  3. #3
    Active Amateur havana_joe's Avatar
    Join Date
    Dec 2009
    Location
    Mansfield, MA
    Posts
    182

    Re: 4 GB Kingston SDHC- E-PL1 issue?

    Quote Originally Posted by OldClicker
    At least half of the card problems I hear about are Kingston. - TF

    Hmmm... Any idea what a good brand would be? The Olympus site only lists compatibility for Sandisk and Toshiba cards, either class 6 or class 10, with the PEN cameras. I'd like something that's a good mix of speed, size, and cost. I don't plan to do a ton of video recording. Maybe something 8 GB with a good reputation? Is Sandisk the way to go?
    http://havanajoe08.shutterfly.com/

    Olympus E-PL1

    Feel free to edit my photos!

  4. #4
    Liz
    Liz is offline
    Moderator Emeritus Liz's Avatar
    Join Date
    Jan 2004
    Location
    New Jersey
    Posts
    5,983

    Re: 4 GB Kingston SDHC- E-PL1 issue?

    Quote Originally Posted by havana_joe
    Hmmm... Any idea what a good brand would be? The Olympus site only lists compatibility for Sandisk and Toshiba cards, either class 6 or class 10, with the PEN cameras. I'd like something that's a good mix of speed, size, and cost. I don't plan to do a ton of video recording. Maybe something 8 GB with a good reputation? Is Sandisk the way to go?
    I use Sandisk exclusively - basically because I began with Sandisk and never had a problem.

    If you are going to do video, Class 6 or above. If no video, even Card 4 is fine. If you do RAW, you will need 8G.....

    Here are a few suggestions:

    Sandisk HDHC Ultra 8G Class 4. Amazon has free shipping over $25

    http://www.amazon.com/SanDisk-Ultra-...4902127&sr=1-5

    Sandisk Extreme 8G Class 10

    http://www.amazon.com/Sandisk-Extrem...902127&sr=1-11

    Liz

  5. #5
    Active Amateur havana_joe's Avatar
    Join Date
    Dec 2009
    Location
    Mansfield, MA
    Posts
    182

    Re: 4 GB Kingston SDHC- E-PL1 issue?

    Quote Originally Posted by Liz
    I use Sandisk exclusively - basically because I began with Sandisk and never had a problem.

    If you are going to do video, Class 6 or above. If no video, even Card 4 is fine. If you do RAW, you will need 8G.....

    Here are a few suggestions:

    Sandisk HDHC Ultra 8G Class 4. Amazon has free shipping over $25

    http://www.amazon.com/SanDisk-Ultra-...4902127&sr=1-5

    Sandisk Extreme 8G Class 10

    http://www.amazon.com/Sandisk-Extrem...902127&sr=1-11

    Liz
    Ok, thanks for the info Liz! One question though, I did shoot some test video using my 2 GB Sandisk SD card, which is only class 2, and it seemed to have worked. What advantage would the class 6 provide? Would a class 4 not work, I've seen a few 4 GB and 8 GB class 4 cards on sale…
    http://havanajoe08.shutterfly.com/

    Olympus E-PL1

    Feel free to edit my photos!

  6. #6
    Liz
    Liz is offline
    Moderator Emeritus Liz's Avatar
    Join Date
    Jan 2004
    Location
    New Jersey
    Posts
    5,983

    Re: 4 GB Kingston SDHC- E-PL1 issue?

    Quote Originally Posted by havana_joe
    Ok, thanks for the info Liz! One question though, I did shoot some test video using my 2 GB Sandisk SD card, which is only class 2, and it seemed to have worked. What advantage would the class 6 provide? Would a class 4 not work, I've seen a few 4 GB and 8 GB class 4 cards on sale…
    That's a good question. If it worked for you, then I'm assuming that it's okay for videos shot with the PEN. I think it depends on the length of the video too. At any rate, I wouldn't spend more money for Class 6 if you don't need it.

    I hope someone else chimes in here.

    BTW, you might consider asking this question in a separate post on the "Helpfile" forum. I think you'd get more "intelligent" and knowledgeable replies.

    Liz

  7. #7
    Active Amateur havana_joe's Avatar
    Join Date
    Dec 2009
    Location
    Mansfield, MA
    Posts
    182

    Re: 4 GB Kingston SDHC- E-PL1 issue?

    Quote Originally Posted by Liz
    That's a good question. If it worked for you, then I'm assuming that it's okay for videos shot with the PEN. I think it depends on the length of the video too. At any rate, I wouldn't spend more money for Class 6 if you don't need it.

    I hope someone else chimes in here.

    BTW, you might consider asking this question in a separate post on the "Helpfile" forum. I think you'd get more "intelligent" and knowledgeable replies.

    Liz
    Thanks Liz! I only posted it here as I didn't know if it was specific to this camera. Weird thing, after work I looked at the 4 GB card, it's a class 4, I formatted it on my computer again, but only a quick format this time, and I tried it in the E-PL1 again, and it seems to be working now. I took about 30 quick snaps, recorded a 30 second and a 6 minute video, and it worked. I deleted them all manually and snapped some more, it seems to be reading the card correctly. I'll keep some backup 2 GB SD cards on hand, if I get any more errors then I'll pick up an 8 GB class 6/10 and be done with it! Thanks again!
    http://havanajoe08.shutterfly.com/

    Olympus E-PL1

    Feel free to edit my photos!

  8. #8
    Liz
    Liz is offline
    Moderator Emeritus Liz's Avatar
    Join Date
    Jan 2004
    Location
    New Jersey
    Posts
    5,983

    Re: 4 GB Kingston SDHC- E-PL1 issue?

    Quote Originally Posted by havana_joe
    Thanks Liz! I only posted it here as I didn't know if it was specific to this camera. Weird thing, after work I looked at the 4 GB card, it's a class 4, I formatted it on my computer again, but only a quick format this time, and I tried it in the E-PL1 again, and it seems to be working now. I took about 30 quick snaps, recorded a 30 second and a 6 minute video, and it worked. I deleted them all manually and snapped some more, it seems to be reading the card correctly. I'll keep some backup 2 GB SD cards on hand, if I get any more errors then I'll pick up an 8 GB class 6/10 and be done with it! Thanks again!
    You're welcome! I hope it keeps on working! Enjoy your camera....and post some pics when you get around to it. :thumbsup:

    Liz

  9. #9
    Active Amateur havana_joe's Avatar
    Join Date
    Dec 2009
    Location
    Mansfield, MA
    Posts
    182

    Re: 4 GB Kingston SDHC- E-PL1 issue?

    Quote Originally Posted by Liz
    You're welcome! I hope it keeps on working! Enjoy your camera....and post some pics when you get around to it. :thumbsup:

    Liz
    Well, I had to buy a different card. The Kingston was fine for pictures, but class 4 is just not fast enough for video. In fact, I could only record about 15-30 seconds of video and then the camera would "crash"- it would stop recording, the write icon would keep flashing, and then it would say "CARD ERROR" and that would be it. I tried it several times, one time it crashed so badly that I couldn't even read the pictures; I put the card in my computer and recovered them there. I don't record video often but if doing so is going to crash the camera and corrupt the files, then I need a different solution!

    I bought a Sandisk Extreme 4GB class 10 SDHC. I was going to go with the 8GB, but 4 should be enough for my needs. It works perfectly, I recorded 8 minutes of video, as a test, and it was fine. I guess when the manual says to use at least a class 6 card, I should have believed it!
    http://havanajoe08.shutterfly.com/

    Olympus E-PL1

    Feel free to edit my photos!

  10. #10
    Liz
    Liz is offline
    Moderator Emeritus Liz's Avatar
    Join Date
    Jan 2004
    Location
    New Jersey
    Posts
    5,983

    Re: 4 GB Kingston SDHC- E-PL1 issue?

    Quote Originally Posted by havana_joe
    Well, I had to buy a different card. The Kingston was fine for pictures, but class 4 is just not fast enough for video. In fact, I could only record about 15-30 seconds of video and then the camera would "crash"- it would stop recording, the write icon would keep flashing, and then it would say "CARD ERROR" and that would be it. I tried it several times, one time it crashed so badly that I couldn't even read the pictures; I put the card in my computer and recovered them there. I don't record video often but if doing so is going to crash the camera and corrupt the files, then I need a different solution!

    I bought a Sandisk Extreme 4GB class 10 SDHC. I was going to go with the 8GB, but 4 should be enough for my needs. It works perfectly, I recorded 8 minutes of video, as a test, and it was fine. I guess when the manual says to use at least a class 6 card, I should have believed it!
    I'm glad you were able to recover your images.....and that the new card works!

    Liz

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •